Ubuntu: Paket für libdvdcss erstellen

2010-09-08 10:09

Falls VLC die folgende Meldung bringt, dann fehlt dem System libdvdcss:

libdvdread: Encrypted DVD support unavailable.

                                           

  No css library available. See            

  /usr/share/doc/libdvdread4/README.css    

  for more information.                    

                                           

********

Wenn gerade keine libdvdcss in den Repositorys findet, dann machs dir selbst (natürlich in einer Shell):

wget http://download.videolan.org/pub/libdvdcss/1.2.9/libdvdcss-1.2.9.tar.bz2

tar -xjf libdvdcss-1.2.9.tar.bz2

cd ./libdvdcss-1.2.9

sudo apt-get install build-essential checkinstall automake1.9

./configure --prefix=/usr

make

sudo checkinstall

Checkinstall fragt einige Informationen über das Paket ab. Wenn das Paket nicht veröffentlicht werden soll, kann man so lange Enter drücken, bis sich

Danach hat man ein .deb, welches man bequem mit dem Paketmanager (de)installieren kann. Musste ich die Tage mal machen, weil ich die lib für nen 64Bit-System wollte. Wohl bekomms!

Update, 01.03.2013: Anleitung für Ubuntu 12.04 / 12.10 aktualisiert. Meldung von VLC hinzugefügt.

via